A Hacker first attempt to find out wordpress version before they start doing their evil work. They know very well which version of wordpress has security loophole and give them easy access to wordpress backend without disturbing site owner.

So as a wordpress site developer or security optimizer, you need to remove wordpress version from source code at the very beginning as soon as start doing wordpress security optimization.

Download WP Code Snippet